Commit 03268918 authored by Matthieu's avatar Matthieu
Browse files

Merge branch 'dependencies' into 'master'

Update dependencies

See merge request !370
parents e1a35f21 4194078c
Pipeline #729 canceled with stages
in 6 minutes and 44 seconds
......@@ -7,6 +7,9 @@ apply plugin: 'kotlin-android'
apply plugin: 'kotlin-kapt'
apply plugin: 'jacoco'
// Force latest version of Jacoco, initially done to resolve https://github.com/jacoco/jacoco/issues/1155
jacoco.toolVersion = "0.8.7"
android {
......@@ -41,8 +44,6 @@ android {
}
testBuildType "staging"
buildTypes {
debug {
applicationIdSuffix '.debug'
......@@ -76,6 +77,13 @@ android {
proguardFiles 'proguard-rules.pro'
}
}
/**
* Make a string with the application_id (available in xml etc)
*/
android.applicationVariants.all { variant ->
variant.resValue 'string', 'application_id', variant.applicationId
}
testOptions {
animationsDisabled true
......@@ -89,15 +97,6 @@ android {
apply plugin: 'kotlin-kapt'
}
afterEvaluate {
/**
* Make a string with the application_id (available in xml etc)
*/
android.applicationVariants.all { variant ->
variant.resValue 'string', 'application_id', variant.applicationId
}
}
dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
......@@ -149,13 +148,13 @@ dependencies {
implementation 'com.google.android.material:material:1.3.0'
//Dagger (dependency injection)
implementation 'com.google.dagger:dagger-android:2.35.1'
implementation 'com.google.dagger:dagger-android-support:2.35.1'
implementation 'com.google.dagger:dagger-android:2.37'
implementation 'com.google.dagger:dagger-android-support:2.37'
// if you use the support libraries
kapt 'com.google.dagger:dagger-android-processor:2.35.1'
kapt 'com.google.dagger:dagger-compiler:2.35.1'
kapt 'com.google.dagger:dagger-android-processor:2.37'
kapt 'com.google.dagger:dagger-compiler:2.37'
implementation 'com.squareup.okhttp3:okhttp:4.9.0'
implementation 'com.squareup.okhttp3:okhttp:4.9.1'
implementation 'com.squareup.retrofit2:retrofit:2.9.0'
implementation 'com.squareup.retrofit2:converter-gson:2.9.0'
implementation 'com.squareup.retrofit2:adapter-rxjava2:2.9.0'
......@@ -180,13 +179,13 @@ dependencies {
implementation 'androidx.legacy:legacy-support-v4:1.0.0'
implementation 'com.mikepenz:materialdrawer:8.4.0'
implementation 'com.mikepenz:materialdrawer:8.4.1'
// Add for NavController support
implementation 'com.mikepenz:materialdrawer-nav:8.4.0'
//iconics
implementation "com.mikepenz:iconics-core:5.2.8"
implementation 'com.mikepenz:materialdrawer-iconics:8.4.0'
implementation 'com.mikepenz:materialdrawer-iconics:8.4.1'
implementation "com.mikepenz:iconics-views:5.0.3"
implementation 'com.mikepenz:google-material-typeface:3.0.1.4.original-kotlin@aar'
......
// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
ext.kotlin_version = '1.4.32'
ext.kotlin_version = '1.5.20'
repositories {
google()
mavenCentral()
}
dependencies {
classpath 'com.android.tools.build:gradle:4.1.3'
classpath 'com.android.tools.build:gradle:4.2.1'
classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
// NOTE: Do not place your application dependencies here; they belong
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment